Magento javascript 404 breaks Admin menu…solved!

May 12, 2009

This is just a quick post about the Magento javascript giving a 404 error because it tripped me up and really shouldn’t trip anyone up. Basically the problem is the javascript include in Magento that looks like the one below gives a 404 error and causes javascript errors on the page:

<script type="text/javascript" src="http://example.com/js/index.php?c=auto&amp;f=,prototype/prototype.js,prototype/validation.js..../>

The problem

Trying to load the javascript URL directly in a browser gives a 404 error, which in turns breaks everything javascript related in Magento. For example the checkout page will no longer work, the Magento admin menus do not display which then causes the whole admin interface to be unusable.

The fix

Set the correct permissions on the javascript files in you Magento installation.

cd /path/to/your/magento/
chmod -R 755 js/*

That should get the javascript files showing up again without the 404 error, and once they are, your Magento admin interface, add to cart, checkout and everything else that relies on javascript, will also work, yah!

Ashley

Posts

Hi! I'm Ashley Schroder, a Software Engineer from New Zealand - this is a collection of notes on my experiences with Ecommerce Web Development, particularly Magento Development.

Are Your Customers Getting The Magento Emails You Send?

MageSend Magento Email sending with Amazon SES

I have made a premium Magento Extension called MageSend. MageSend makes it simple and easy to send using Amazon's highly reliable SES email service.

The extension is $99, and comes with a complete money back guarantee, please check it out, I am confident it will resolve any email sending problems with your Magento store.

3 responses to Magento javascript 404 breaks Admin menu…solved!

  1. Thank you!!! This page just solved this problem for me! Javascript had broken after an upgrade from Magento 1.3.2.2 to 1.3.2.4. I chmodded to 755 and it works! Thank you again for this post!

  2. Hi tried this and worked, got my menu back in admin, but back to same old issue when i click on the menu manage categories it gives me blank screen!!

  3. hey great job bro…thanks you very much….. 🙂